Unable to attach postgres app

Hi! I am trying to deploy my Rails application & I ran my first command fly launch. I created a Postgresql database, selected the configuration of ‘Development - Single node’, and chose ‘yes’ for the ‘single node pg to zero after one hour?’ prompt.

After a while, it created the database and returned its credentials but it failed to attach the Rails app to the PostgreSQL cluster. The error log:

Failed attaching gratify-me to the Postgres cluster gratify-me-db: Get "http://............../commands/databases/.........": connect tcp [...............]:5500: operation timed out.

I tried to attach it manually with this command:
fly postgres attach --app gratify-me gratify-me-db
but it returns the same error of operation timed out

How can I fix this error? Any help would be appreciated a lot! Thanks! :slight_smile:

If this helps, running fly image show --app gratify-me-db outputs the following:

MACHINE ID    	REGISTRY            	REPOSITORY         	TAG 	VERSION                                                               
4***********87	registry-1.docker.io	flyio/postgres-flex	15.3	v0.0.42
1 Like

I had the same problem. After running ‘fly version upgrade’ it worked.

1 Like