Turboku chokes with either allowed spaces in names or allowed hyphens in heroku app names

I created a new account with a user name that has a space in it (to be clear, the username seems to be “alexati”, but the full name is “Alex Ati”), and tried to import from heroku an app called “hohoho-hohoho”.

Both through the turboku import web page and through flyctl I get an error stating “Error Validation failed: Name only allows letters, numbers, and underscores”.

I can’t change the heroku app name but I tried taking the hyphen out of the fly app, with “hohohohohoho”, to no avail.

I also tried creating a new org, as I see that my default org, called “personal” in “flyctl orgs list” and “Personal” also in the dashboard org dropdown, is named after my name, that has a space. In Heroku · Launch on Fly.io, for example, I see my name as the name of the org, not “personal”.

So either the space in the org name or the hyphen in the heroku app name is making turboku fail. I’m inclined to think that the small inconsistency of the personal org being named “personal” or username depending where you look at, hints that an assumption somewhere in turboku may be invalid.

Is there a way to rename my personal organization? Any other ideas, besides renaming my heroku app (can’t go that route)?