Stuck on "Unpacking image"

My app (cave-demos) was stick at “Unpacking image” during the deploy process.

I deleted the app and recreated (seems like there’s no way to initi an application with an existing config?) which solved the build issue. At this point, for some reason, the app was unavailable at https://cave-demos.fly.dev

Assuming it was a stale cached route, I redeployed to “cave-demo.fly.dev” and everything worked!

Although now, when I redeploy that app I’m stuck at “Unpacking image” again.

huh! looks like community.fly.io is hosted on fly.io and when the discourse instance crawled my app I got an ipv6 request ip! that’s a first for me

[GIN] 2021/01/18 - 18:00:20 | 200 |     156.493µs | 2001:470:14e:5:0:274:2edb:fac | GET      "/"

You can run fly init newappname --import fly.toml and flyctl will try to init the new app and the config in fly.toml and put them together for you. It’ll ask if you want to overwrite fly.toml - you can say yes as its completely read in before it writes the new one out.

1 Like

@Codepope ah, I did not read the command line options closely enough, thanks!

Freezing on “Unpacking Image” seems to have stopped in the latest deploy.

We’re debugging that “Unpacking image” freeze. It’s happening on one particular host that we’ve temporarily disabled.