Static files suddenly not found

All the static files for my django app suddenly starting returning 404s today. I tried redeploying and that did not fix the issue. Before there had been no deploys for 8 days, so I’m not sure why they suddenly stopped working. Anybody else having a similar issue?


Same here. Previous (really old deploy) worked fine. After the deploy today the static assets are no longer served, I double checked they are in the actual vm.

Not sure why they were working and now they aren’t but I added whitenoise and that fixed the issue.

same here too!

I’m looking into this.


@bgaudino did you add whitenoise and keep the [[static]] configuration or did you remove it and essentially not using the fly proxy for the assets?

thank you. bit more info as it may be relevant, disregard if not!

my last deploy was done yesterday with flyctl 0.1.139

app name is sc-app

statics was working fine earlier today around 4h ago, I only noticed the downtime 30m ago or so.

@Ralph I left my fly.toml as is

1 Like

Also seeing this and am disappointed in for not really providing any updates :frowning:

Same issue here. We have half a dozen apps across three separate orgs, some with deploys over 2 months ago that have been working fine. All Django apps.

Today, I check and every single one of them is 404 on static files.

We fixed one issue with statics earlier today, but it looks like a different issue came up in the meantime. I’m going to look at first thing tomorrow morning, sorry about that.


I took a look just now and pushed a quick fix, disabled something I was testing earlier that ended up interacting badly with statics. I’ll deploy a proper patch tomorrow morning, but statics should be working properly now; please let me know if you’re still having issues.


I’m still having this issue. My app is a remix app (JS) tho. Not sure if that matters. Our statics stopped working around 30h ago.
Is a redeploy needed for this to work again?

In my case, Django apps in two of my orgs now have working statics, and one (the oldest to have been deployed) does not

can I get examples of URLs that are not working? I can take a look. if you don’t want to post publicly

Sure thing:

these used to work. this is our statics config:

  guest_path = "/data/cdn"
  url_prefix = "/cdn"

These urls are being redirected to our app, which doesn’t know how to handle them.
Before these were served by the /data/cdn directory in our volume and didn’t reach the app at all.

Looks like there was some bad state left over for your app (unrelated to yesterday’s issues), I just cleaned it up.

1 Like

It is working now. Thanks!

Hey @lillian I just found my site without assets, is this also due to a bad left over state (do I need to redeploy?) Or do you still work on a full fix?

Page w/a assets:

Update here, re-deploy here did not help.