Some assets (a subset of all images) not deployed


I’m getting a weird behavior upon deploying a relatively out-of-the-box Phoenix 1.7 app - about 80% of the images under /priv/assets/images are seemingly not deployed - not available via http, nor in the file system on the app’s machine.

I’m not sure where the problem lies, but here’s some background and what I’ve tried so far:

  • I’ve got around 40 images under /priv/assets/images in a Phoenix app.
  • Some 5 of them do get deployed and are available, I don’t see any pattern into which 5, but after multiple deployments I can say that it’s always the same 5.
  • I’ve looked under /app/lib/my_app-0.1.0/priv on the VM - only those 5 files are present.
  • I’ve deleted all of priv/assets/images and redeployed - all images gone, then restored them and redeployed - same, only those 5 are there.
  • I’ve tried fly deploy with and without --remote-only.
  • I’ve recreated the builder machine (in hopes of removing any docker caches).

The phoenix app has been created by a simple mix, here’s the config for Plug.Static:

plug Plug.Static,
    at: "/",
    from: :pointex,
    gzip: false,
    only: MyAppWeb.static_paths()

in the MyAppWeb module:

  def static_paths, do: ~w(assets fonts images favicon.ico robots.txt)

The whole deployment config has been initialized using flyctl following the official guide.
The Fly app is still on v1, not sure if this matters.

Does anyone have any idea what can be causing this glitch and how I could go about solving it?

Thanks in advance!