[SOLVED] Can't deploy, can't launch Phoenix app


  • I’m on hobby plan (NRT region)
  • Previously created a simple phoenix app with postgres, was working fine for months
  • In the past month, deploys became erratic (hanging, failing, then working again)

I can’t launch a fresh phoenix app or postgres db at all because fly launch hangs on

Provisioning 1 of 1 machines with image flyio/postgres

What I’ve tried

  • Trashing all apps, deleting Dockerfile + fly.toml
  • reinstalling flyctl
  • Signing up for a new fly.io account
  • Using a different terminal on Mac
  • Changing wifi networks

I want to upgrade my plan to pay for support, but it makes little sense if I can’t deploy a demo app on the hobby plan. Any ideas/advice would be greatly appreciated otherwise I’ll have to switch platform.

For those who hit similar issues, here’s how I got past it:

  • Waited a bit
  • Restarted my Mac (!)
  • Tried again

My suspicion is that it was something to do with the flyctl proxy command somehow hanging and affecting the creation of a new postgres db. Probably should have restarted my mac before signing up for a new account!