Remote deploy times out on steps that rely on


I’m trying to deploy a fairly straightforward Phoenix app, no tricks or anything, just following the tutorial on Phoenix’s (1.6.0-rc0) side.

When I deploy remotely (which I have to due to my M1 Mac), the builder seems to arbitrarily time out on either:

  • mix local.rebar --force (citing Could not install Rebar because Mix could not download metadata at
  • mix deps.get --only $MIX_ENV. It complains about Failed to fetch record for 'hexpm/cowboy_telemetry' from registry (using cache instead). Of course, cowboy_telemetry exists on Hex.

I’m wondering if this is an availability problem on Hex’s side? Their status seems all green, and running the steps locally works fine as well. Did I mess up my networking config somehow, or is this a known problem?

That’s interesting. If you’re getting errors from those commands in the builder, it’s either a network issue between the builder and hex, or an actual hex problem. I think most Hex stuff is on S3 so it might just be a regional S3 problem.

How long has this been happening?

For a couple hours - though I remember when I tried to deploy something a week or so ago, I was also having issues with mix local.rebar on my remote builder.

Hrm, just ran deploy again and it worked for those steps. Maybe it’s just an AWS blip then?

What is weird, though, is that my builder is on fra, so it’s assumedly talking to the same AWS region that I am (being in Berlin). Locally, on my machine, it works consistently, but on the remote builder it seems less consistent.

I just moved your builder to Amsterdam, will you give that a try and see if it helps?

Yep, that seems to be fine for now.

Well that’s super weird. S3 is a pain.

1 Like