Error starting Hex application

Got this error trying to deploy my first elixir phoenix app. I was following the elixir deploy guide and have the same Dockerfile as the example repo:

Any ideas? I have 0 devops/deploy experience lol

Whoah I’m sorry we missed this post! Did you figure it out? That looks like it might be using an old version of hex for some reason.

I was able to get it working by adding the --remote-only flag.

I am on a M1 Mac so :man_shrugging:. I will try the out of date hex idea and see if that fixes it. Would love to understand more about why it failed so I can be better at debugging these kind of things in the future.

Frontend dev trying to move fullstack thanks to how easy Phoenix makes that transition.

1 Like

Hi @will-king, thanks! Today had the same error and the --remote-only flag worked for me. I’m also on a M1 Mac. Any idea why the error occours?

This is a known issue with Apple M1 builds. Our launcher defaults to deploying with --remote-only. Which guide are you following?

1 Like

Hi @joshua, I didn’t realise it’s a know issue with Apple M1. I followed the getting started Elixir guide. Not sure why the --remote-only flag is not default in my case (fly version 0.0.269) but it’s not a big deal for me.

Thanks

Docker on m1 Macs is all kinds of buggy. And difficult to debug, using remote-only was the right thing to do here.