Remote chrome dev tools debugging

Hi! I run a node process started with node --inspect= (which I can safely do since it declares no service and its app doesn’t have any public IP address), I am trying to create a tunnel so that I can debug it locally with Chrome DevTools, so I run:

fly proxy 9230:9229

And add localhost:9230 to the target discovery settings of chrome://inspect, unfortunately Chrome doesn’t find my node process.
I also tried different local ports (and the default 9229) with no more success.

Is there anything obvious I missed?


I can also confirm that in my app logs I do see:

Debugger listening on ws://

If you’re talking to it over a WireGuard tunnel (ie, with flyctl proxy), it’ll need to bind to its fdaa: IPv6 address — you can’t talk IPv4 over our WireGuard tunnels.

Thanks, it works perfectly now! :slightly_smiling_face:

Yay! I did a tech support! :slight_smile:

1 Like

I’m trying to do the same thing (but debugging through IntelliJ), and I’m having trouble following the solution posted here to get it to work. Could you add some more details about exactly what needs to be done here? I’m running node --inspect=, running fly proxy 9229, grab the fdaa IPv6 address from fly ips private, and then set the debugger to attach on that address and port 9229, but I always get “cannot connect to /[ipv6 address]:9229”