Problems with fly proxy

I’m having issues with the fly proxy command to establish a proper connection to a nREPL-server I have running at port 7000. I can access it locally from a Docker container, and through fly ssh console.

Are there any ways to establish a “normal SSH port forward” – or is there some IPv6 or other things that I need to be aware of when using fly proxy?


It needs to bind to [::] (all ipv6 and ipv4), at least that’s simplest. It could also only bind to your private ipv6 (fdaa:...), but that’s a bit harder to arrange.

Looking at nREPL, it sounds like you need to run it with -b ::

Thanks! I already tried and :: to no avail. Both fly proxy and wireguard SSH local port forward don’t work. I can connect with netcat directly in the machine with all options.

Do I need to define the port in fly.toml – already added an additional [[ service ]] section with port 7000 (no external binds) but that did not help either.

Can you confirm it is indeed binding to all interfaces?

lsof -i

should give you the information you need.


java 523 root 38u IPv6 4607 0t0 TCP localhost:7000 (LISTEN)

So – there it is. It says it was bound to :: but it in fact isnt? I will investigate more.


That does look like the problem! :slight_smile:

1 Like

Is the private IP the same for all deployments in the same region? I was thinking to bind to the private IP mentioned in /etc/hosts to see if that makes any difference.

It’s a different one per VM. There should be a local-6pn entry (or something like that) in the etc hosts file.

1 Like

OK. This is so dumb. Classic PEBKAC -situation. I had used host instead of bind in my nREPL settings and the parameter just was not used anywhere. Thanks again for helping out!

1 Like