Remix Basic Deployment does not work

I followed the instructions here to tee.

It did not work multiple times. I even tried to uncomment the remix.config.js to the following and it still didn’t work.

/** @type {import('@remix-run/dev').AppConfig} */
module.exports = {
  ignoredRouteFiles: ['**/.*'],
  appDirectory: 'app',
  assetsBuildDirectory: 'public/build',
  serverBuildPath: 'build/index.js',
  publicPath: '/build/',

Nom run dev works, but deploying and going to the host name does not.

Hi @goodunionjobs

What error message do you see when the remix deploy fails?

I know some of our documentation needs updating so I tried following this tutorial myself but was able to deploy the remix app.

However I did run into this error message Error error building: failed to compute cache key: "/package-lock.json" not found: not found
when I selected no to the option to run npm install.

If you’re seeing similar errors to that I would run through the tutorial again and ensure to accept to run npm install.