qemu: uncaught target signal 11 (Segmentation fault) - core dumped when running flyctl deploy

Getting this error occasionally when running flyctl deploy on my M1 mac:

qemu: uncaught target signal 11 (Segmentation fault) - core dumped

It sometimes deploys successfully after restarting docker. Works around 3 out of 5 times.

Any help appreciated

Sheesh, you’re the second person to encounter this today!

This is an issue with some images being emulated on the M1. Simplest fix is doing the build on a remote docker builder using the —remote-only flag.

Edit: my phone might be turning those two dashes into a long dash. It is two dashes though.

hmm… stuck on this
Waiting for remote builder fly-builder-throbbing-sunset-1342... starting ⣻

and I get this after a while
Error waiting for remote builder app: context deadline exceeded

this is the full command I’m running

"deploy": "flyctl deploy --remote-only --build-arg REMIX_TOKEN=${REMIX_TOKEN}",

There was an issue placing your VM that I’m still investigating. Could you try again when you have a moment? I deleted the failing builder app so you’ll can get a new one next time you deploy.

Thanks. got pretty close, but still errored out.

Digest: sha256:f5de337f254ab30ad5ee292f11db11efe8a97cc1fcbdf1689344113abe1973c3
Status: Downloaded newer image for heroku/pack:20
Error executing lifecycle: io: read/write on closed pipe

Sorry I missed your reply. That looks like a network error during the build. Were you able to get it working?