different docker hosts -- why? And why am I getting a segmentation fault when I try to deploy?

Why I type fly deploy on my laptop here in Pennsylvania I see log output in my terminal that indicates:

==> Building image with Docker
--> docker host: 20.10.8 linux aarch64

But when my business partner in India runs the same command (from exact same branch/git commit of our codebase) he sees:

==> Building image with Docker
--> docker host: 20.10.8 linux x86_64

My question is: why are they different? We would like our builds / deploys to be identical as much as possible.

Also, we have been having an issue where the deploy succeeds when he runs it, but when I run it I get an error:

qemu: uncaught target signal 11 (Segmentation fault) - core dumped

So I can’t deploy, but he can. What’s up with that?

Ok, so I got some help here: Docker Build & Deploy Fail on Apple M1

I am on an Apple M1, which is apparently an issue.

If I run

LOG_LEVEL=debug fly deploy --remote-only

the it seems to succeed.

1 Like

Yeah, if you want the most standardization, all your team members can use —remote-only or put it on the CI system. That way you’ll always build inside the Fly builder app.