Problem connecting to app instance (Error 2000)

Hi all,

When deploying my code, I’m getting these errors regardless of the region and not just after deploying, but since more than a day now and sometimes more than 10 times a second:

error.message="problem connecting to app instance" 2022-02-01T22:03:11.910 proxy[b436dd06] ams [error]error.code=2000 

This also happens when I remove the health check from the fly.toml. Also, my health checks indicate that there are CONNRESET and CONNREFUSED errors happening quite randomly which also result in 525s at Cloudflare or plain browser errors similar to the error codes when bypassing Cloudflare.

Any idea where this is coming from? Any help or clues would be appreciated. :S

Edit: I’ve seen multiple similar threads about this that have been solved, but indicated health checks or errors around the time of deployments.


What type of app is it?

As for health checks, does the fly.toml file ports match up with the app?

Ports do match up, but I have the health checks disabled/commented out for now. I can check those later and usually didn’t had much issues with them.

It’s a Dockerfile-based one

Is it Ruby, Go, Elixir, Java, …?

Not sure if it’s required to know, but it might be helpful in recommending tests.

Have you tried deploying on of the “hello” apps for your language/framework? If that works then it’s config issue and you have something to compare against.

1 Like

It’s based on NodeJS, but thanks for the recommendation. For some reason I didn’t think about that yet. Will give it a try tomorrow and report back! :slight_smile:

Good luck! Hope that helps!

1 Like


I can confirm that this was indeed an issue on my end that had to do with too little memory and missing swap that was different on the machines I previously used. After adding the necessary configuration and fixing it, the issue resolved itself for most request hitting our app.

Thanks for the quick response though and sorry for flagging this false alarm! :slight_smile:

1 Like

Glad you were able to get it resolved!

1 Like