Postgres "server misbehaving" error messages

Since about an hour or two I get the following errors messages when trying to connect to the postgres database from our app on

dial tcp: lookup top2.nearest.of.kantara-staging.internal on [fdaa::3]:53: server misbehaving

However connecting to the postgres instance via fly proxy is working as expected and all health checks are passing. Maybe an internal networking issue?
I tried running fly wireguard reset but that didn’t fix it.

Any advice on how to get our services back up?

Is this still not working?

Yes. The issue still persists. Tried multiple restarts of the postgres and app but still getting the same error message.

not sure if it is related or not but I’m also having issues with Postgres

my app can’t connect (nor I can deploy right now) to it and checking monitors, I see this

No idea what check is failing, tried to restart but it didn’t help

Im having the same issue. Both my staging and prod envs cant connect to their databases, giving this error (both dbs are on the same instance). not sure when this started

I first noticed that my app went offline yesterday night but as is just a pet project, I delayed doing something until now

My apps are back online, i did nothing to fix it. Some sort of outage i guess

We just found and fixed an issue with the DNS service that runs on the server where your app is allocated. We are looking for similar issues in other servers, but glad to hear it is working for you.


I can confirm that my app is now working as expected. Thanks for the fix!

1 Like