Pointing to a domain

Hi there - I’ve successfully deployed my app to fly and I now want to point it to my app’s domain (www.example.com).

I’ve been following Fly’s docs on this but it doesn’t seem to be working (my certs, for instance, are yet to be issued even after a day). The steps I’ve followed thus far are:

  • flyctl ips list to get the A and AAAA record (which I have included in Namecheap - my domain manager)
  • I have also included the CNAME (I got this from the certs tab on Fly’s dashboard)
  • flyctl certs create (both for example.com and www.example.com).

Show cert command says that my certificate has yet to be issued and nothing comes up when I visit www.example.com.

Have I missed something? Or does this process take a while?

If it makes a difference, my site isn’t exactly an app. It’s a static site built using Hugo.

Try these commands, and make sure you get the same results, and that they show the fly ips list IPs:

dig a example.com +short
dig a www.example.com +short
dig aaaa example.com +short
dig aaaa www.example.com +short

fly certs check www.example.com may also provide more details.

The certificate for example.com has now been issued but not for www.example.com.

I get the same ips results for the dig commands (example.com). I don’t get anything for www.example.com though (is it because the cert has yet to be issued?).

strange it takes such a long time to get a domain set up on fly…

Also when I run fly certs check www.example.com, it says cert not yet issued and it mentions a cname (www.app-name.fly.dev) which is different to the one shown on my dashboard. I’m assuming I go with the one on my dashboard?

Ah, no results is a problem. That means your DNS provider doesn’t have the right entries for www.example.com.

If you don’t see a result when you run dig cname www.example.com +short, something isn’t configured properly on the Namecheap end. You should see what our UI says for that query.

I hadn’t added A and AAAA records with ‘www’ as the host (I had only done that for @). The certificate for www.example.com has now been issued and my dashboard now says that both urls have been verified.

But I still see nothing when I visit the URL? The dig commands for www.example.com still doesn’t show anything…

It works now… maybe it just takes a while.
Thanks! :pray:t4:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.