Oops something went wrong

Any idea why I am getting this error when running fly postgres config view?

Oops, something went wrong! Could you try that again?

Anyone? This still isn’t working.

Was there a request ID printed when this happened?

Nope, maybe try yourself :slight_smile:

fly postgres config view -a catadesk-staging-db

A tip: If you compile flyctl yourself, such failing commands should then print the actual stack trace. There’s a bunch of nil references that trip the code up, which are quick fixes.

I think, flyctl should have a switch, say -vv, to show underlying errors. I mean, flyctl users are all developers, anyway.

This is still not working. Could someone look at this?


Could you send us the output for the following commands?

Flyctl version: fly version

Image version: fly image show

App status: fly status --app <app-name>

Fly doctor: fly doctor

Just tried and it worked for me:

~$ fly postgres config view -a catadesk-staging-db
NAME                            VALUE   UNIT    DESCRIPTION                                                                                     PENDING RESTART
log-min-duration-statement      -1      ms      Sets the minimum execution time above which all statements will be logged. (-1, 2147483647)     false
log-statement                   none            Sets the type of statements logged. [none, ddl, mod, all]                                       false
max-connections                 600             Sets the maximum number of concurrent connections. (1, 262143)                                  false
shared-buffers                  8192    8kB     Sets the number of shared memory buffers used by the server. (16, 1073741823)                   false
shared-preload-libraries                        Lists shared libraries to preload into server.                                                  false
wal-level                       replica         Sets the level of information written to the WAL. [minimal, replica, logical]                   false
~$ fly version
fly v0.0.0-1668537527+dev darwin/amd64 Commit: <commit> BuildDate: 2022-11-15T18:38:47Z

Yea, we updated the max-connections parameter and now fly config view works again :person_shrugging:

So we can try to improve this a bit, what was it before and what is it now?

300 I think