Oops, something went wrong! Could you try that again? with fresh Remix Indie stack

I’m following the readme for the Remix Indie stack but it fails with “Oops, something went wrong! Could you try that again?” when I run fly create <app name>.

With LOG_LEVEL=debug is gives me this:

➜  route-tracker LOG_LEVEL=debug fly create route-tracker-37a9
DEBUG Loaded flyctl config from/Users/fredriksogaard/.fly/config.yml
DEBUG determined hostname: "Fredriks-MacBook-Pro.local"
DEBUG determined working directory: "/Users/fredriksogaard/Websider/route-tracker"
DEBUG determined user home directory: "/Users/fredriksogaard"
DEBUG determined config directory: "/Users/fredriksogaard/.fly"
DEBUG ensured config directory exists.
DEBUG ensured config directory perms.
DEBUG cache loaded.
DEBUG config initialized.
DEBUG initialized task manager.
DEBUG skipped querying for new release
DEBUG client initialized.
DEBUG --> POST https://api.fly.io/graphql

  "query": "query { organizations { nodes { id slug name type } } }",
  "variables": null

DEBUG <-- 200 https://api.fly.io/graphql (371.8ms)

  "data": {
    "organizations": {
      "nodes": [
          "id": "NP9vVpRwXy9omT9O9lYG7qPYGMun3e",
          "slug": "personal",
          "name": "Fredrik Søgaard",
          "type": "PERSONAL"
automatically selected personal organization: Fredrik Søgaard
Oops, something went wrong! Could you try that again?

Fly version is fly v0.0.351 darwin/arm64 Commit: df8c42a6 BuildDate: 2022-07-08T14:15:55Z

Any ideas?


I’m guessing the answer is yes but doesn’t hurt to check :slight_smile: : have you updated the app’s name in your fly.toml to the same one you are using in your fly create <app name>?


I have the exact same issue, with the exact same log.
I have one other similarity with Fredrik’s case, which is that I have a special character in my name.
He has an ø, I have an ë.
Could this be the source of the error?

@fredrik-s the exception I found on our backend makes it look like this error happened because there was no volume created. Did you follow the volumes section in the docs here? GitHub - remix-run/indie-stack: The Remix Stack for deploying to Fly with SQLite, authentication, testing, linting, formatting, etc.

@MickaelH I don’t see an error logged for your user. I’m pretty sure special characters work! Do you remember what command you ran to trigger that error?

I’m following the indie-stack readme file here: GitHub - remix-run/indie-stack: The Remix Stack for deploying to Fly with SQLite, authentication, testing, linting, formatting, etc.

I changed the app name in the fly.toml file, typed the command, and got this:

Hey, so I’m still stuck with this problem…
Any idea how to solve it?

Well that’s weird. Try running fly apps create instead? We’re deprecating fly create (it should still work, though).

@MickaelH I’ve just tried myself using the indie stack, as it is now (npx create-remix --template remix-run/indie-stack) using the latest Fly CLI (fly version update) and it worked. Weird! I updated the name in the fly.toml as it says to, ran the command, and it worked:

fly apps create delete-this-remix-app
? Select Organization: Gregory Sanderson (personal)
New app created: delete-this-remix-app

The only thing that seems to differ is the special character, like you say. I tried making an organisation with one in and it still seemed happy (well, blocked by the need for payment, but no error). I would assume it would use the slug anyway so it seems unlikely it would be that:

fly apps create delete-this-remix-app
? Select Organization: dëletethis (deletethis)
Error We need your payment information to continue! Add a credit card or buy credit: https://fly.io/dashboard/deletethis/billing

Hmm … If you haven’t already I would first get the latest Fly CLI to eliminate that as a variable. And add a payment card, if not already, to prevent that being an issue too.

Then run fly auth whoami to double-check that is indeed the expected (you).

Then, out of interest what happens when you run fly apps list? Do you see your remix app listed at all there, in any state? Likely not but that could be worth checking.

And likewise with fly status. Again, given your error it likely won’t return this, but it would be interesting to know to make sure e.g the name is URL-safe as that is where it’s used. Like I see:

fly status
  Name     = delete-this-remix-app          
  Owner    = personal                       
  Version  = 0                              
  Status   = pending                        
  Hostname = delete-this-remix-app.fly.dev  

Ok so I did a few things:

  • I double checked everything
  • I updated the app as you suggested
  • I ran fly auth whoami to confirm I’m using the correct account
  • I removed the ¨ in my first name in the dashboard just in case
  • And I tried to run fly create again

And now I’m left with more questions than answers ^^

Why wasn’t my name updated when I ran the command again? (Is there a cache I need to clean?)
Why does fly say that it’s already taken? (I would be very surprised if there was another user of Fly with my name) :thinking:

And fly apps list shows nothing

Ah, well that looks like it may have made some progress: at least now you are getting a different error. And one that would be expected. Since the app’s name needs to be globally unique, not just unique in your organisation. That’s because it is used for a DNS name e.g app-name-here.fly.dev. So there can only ever be one app called indie-stack-template across all of Fly. And by “Name has already been taken”, I think it is meaning the app’s name, not your name, has already been taken. Else yes, I’d be surprised :slight_smile:

So … first you see the create command is deprecated. As @kurt mentions, and why getting the latest Fly CLI is handy. So that’s good. Next, you get the name has already been taken error. So that is highly likely to be correct. As it probably has been. So the solution for that is simply to call it a different name, something random of your choice. And put that name in the fly.toml too. So e.g my-app-name-abcde … or whatever other people won’t have picked. And then try it. And it should then work. As mine did.

And then the app will be pending and so would then return in fly apps list and fly status. Which it currently doesn’t.

And then you can proceed on with the other steps in their guide needed for it to then deploy.

Working now. Thanks :slight_smile:

It would be a good idea to explicitly mention which name is already being taken indeed.
The error message was a little bit ambiguous in that regard.

1 Like

I had to upgrade from version 0.0.351 → v0.0.353 to get it working. (When I created the issue version 0.0.351 was the latest version.)