fly proxy crashes with "Oops, something went wrong! Could you try that again?" on Github actions

We’re trying to run fly proxy on a Github action. This has worked before, but now it fails with “Oops, something went wrong! Could you try that again?”

This is flyctl 0.0.410 installed using superfly/flyctl-actions

Full output

Run LOG_LEVEL=debug flyctl proxy 5432 -a xxxxxxx &
DEBUG determined hostname: "fv-az426-632"
DEBUG determined working directory: "/home/runner/work/xxxxxxx"
DEBUG determined user home directory: "/home/runner"
DEBUG determined config directory: "/home/runner/.fly"
DEBUG ensured config directory exists.
DEBUG ensured config directory perms.
DEBUG cache loaded.
DEBUG config initialized.
DEBUG initialized task manager.
DEBUG skipped querying for new release
DEBUG client initialized.
DEBUG no app config found at /home/runner/work/xxxxxxxxxx/fly.toml; skipped.
DEBUG --> POST https://api.fly.io/graphql

{
  "query": "query ($appName: String!) { appbasic:app(name: $appName) { id name platformVersion organization { id slug } } }",
  "variables": {
    "appName": "xxxxxxxxxxxxxxxx"
  }
}

DEBUG {}
DEBUG <-- 200 https://api.fly.io/graphql (63.09ms)

{
  "data": {
    "appbasic": {
      "id": "xxxxxxxxxxxxxxxx",
      "name": "xxxxxxxxxxxxxxxx",
      "platformVersion": "nomad",
      "organization": {
        "id": "xxxxxxxxxxxxxxxx",
        "slug": "xxxxxxxxxxxxxxxx"
      }
    }
  }
}
DEBUG --> POST https://api.fly.io/graphql

{
  "query": "mutation($input: ValidateWireGuardPeersInput!) { validateWireGuardPeers(input: $input) { invalidPeerIps } }",
  "variables": {
    "input": {
      "peerIps": []
    }
  }
}

DEBUG {}
DEBUG <-- 200 https://api.fly.io/graphql (49.07ms)

{
  "data": {
    "validateWireGuardPeers": {
      "invalidPeerIps": []
    }
  }
}
DEBUG started agent process (pid: 1684, log: /home/runner/.fly/agent-logs/1540936782.log)
DEBUG --> POST https://api.fly.io/graphql

{
  "query": "mutation($input: ValidateWireGuardPeersInput!) { validateWireGuardPeers(input: $input) { invalidPeerIps } }",
  "variables": {
    "input": {
      "peerIps": []
    }
  }
}

DEBUG {}
DEBUG <-- 200 https://api.fly.io/graphql (42.57ms)

{
  "data": {
    "validateWireGuardPeers": {
      "invalidPeerIps": []
    }
  }
}
Oops, something went wrong! Could you try that again?
1 Like

Update: it works with flyctl 0.0.403

It still doesn’t work

Thanks for reaching out on this.

We are aware of this issue and we are looking into it

Should be fixed now on fly v0.0.411. Feel free to fly version update now.

1 Like