not enough available dedicated CPUs to fulfill request of 1 cpus

Hi, I’m deploying my application and running into an issue. It really seems like my account is locked or limited?

==> Validating app configuration
--> Validating app configuration done
TCP 80/443 ⇢ 8080
Error unhandled upstream service error: could not fulfill resource requirements: not enough available dedicated CPUs to fulfill request of 1 cpus

I’ve tried multiple regions

This error usually indicates full capacity in the regions you’re trying to launch in — while that’s being handled, the best workaround might be to try again and in more regions. Which regions are you hitting limits in?

Luckily I had the frame of mind to try all that. I tried SEC, LOS, and MIA. I have zero apps.

If I was a betting engineer I suspect I’ve hit some sort of “We think you are a service abuser, so we’re throttling your account to 0”.

That’s actually another message, it’ll say your account is high-risk and ask you to contact support. If you didn’t get any such message you should be fine on that front.

Hmm, especially weird. So here’s exactly what happens:

  1. I deploy
  2. There’s a fly-builder that’s “active”
  3. Thee’s a instance of my app that’s pending
  4. I get this message.

I believe this is fixed, but needed a builder reset. Will you try running again?

If the remote builder doesn’t work, you can install Docker locally to workaround the problem. But it should!

Just writing back that I have successfully deployed. Thanks so much for your effort.

1 Like