Not able to deploy

In the last three hours, I tried deploying 30 times or so. 29 times it failed, 1 time it worked. The deployments Failed due to unhealthy allocations. This is the vm status output:

2023-02-26T04:16:57Z Received Task received by client
2023-02-26T04:16:57Z Task Setup Building Task Directory
2023-02-26T04:16:58Z Driver Failure rpc error: code = Unknown desc = could not fulfill runtime memory request
2023-02-26T04:16:58Z Not Restarting Error was unrecoverable
2023-02-26T04:16:58Z Alloc Unhealthy Unhealthy because of failed task

I tried destroying the app and the builder. Didn’t work. I have absolutely no clue what I should do next. Please help :smiley:

There are more people running in to this, check: Deployments fail immediately due to unhealthy allocations

I have the same issue, you’re not alone

==> Verifying app config
--> Verified app config
==> Building image
WARN Failed to start remote builder heartbeat: You hit a Fly API error with request ID: 01GT6MFMS3P6N2E986GS7407BP-ams
Error failed to fetch an image or build from source: error connecting to docker: You hit a Fly API error with request ID: 01GT6MFNET9PK9P3020FR2CWEN-ams

I can’t deploy since morning. Always get the same error.
I thought the problem was in the account, but deleting the old one and creating a new one did not help.