Image runs fine locally but doesn't work on Fly

I have an existing app that I’ve deployed many times. It’s a very simple single executable container image that runs the thttpd server pointed to a directory full of static HTML content. I made a few minor changes to the base container image and re-deployed around 10 or 15 times, and all of those deploys have failed. Deploys always fail with unhealthy allocation.

I’ve built and run this exact same container locally and it runs without a hitch. Deploys always fail with some error about the main process exiting cleanly with exit code 1, but my local container runs fine. Can you guys provide more info?

Local events from the latest deploy:

Recent Events
TIMESTAMP            TYPE            MESSAGE                                                                    
2021-10-04T16:21:39Z Received        Task received by client                                                    
2021-10-04T16:21:39Z Task Setup      Building Task Directory                                                    
2021-10-04T16:22:35Z Driver Failure  failed to start task after driver exited unexpectedly: plugin is shut down 
2021-10-04T16:22:35Z Not Restarting  Error was unrecoverable                                                    
2021-10-04T16:22:35Z Alloc Unhealthy Unhealthy because of failed task                                           
2021-10-04T16:22:36Z Killing         Sent interrupt. Waiting 5s before force killing

That looks like it’s on our end. We’ve had intermittent failures for the past few hours due to DNS issues which might be related. Can you share your app name or the id of a VM that failed to start?

Failed instance ID: b06df821

Does this help?

Also yesterday, I noticed that scaling down the app and then scaling it back up started my new version somehow.

Yeah that helped, I found your app and can see the logs. Could you try deploying again since the issue has been resolved?

Scaling an app increments the version, but existing VMs are just updated rather than stopped and replaced.

Ah so scaling didn’t fix it either. It’s still not working for me btw. I’m getting the same error about unhealthy allocations.

Its working now!