No love with first deployment attempt of phoenix app

Here is the error:

Sending build context to Docker daemon 53.15kB
[+] Building 0.7s (4/4) FINISHED
=> [internal] load remote build context 0.0s
=> copy /context / 0.1s
=> ERROR [internal] load metadata for docker.io/hexpm/elixir:1.12.2-erlang-24.0.3-debian-bullseye-20220801-slim 0.6s
=> [internal] load metadata for Docker Hub 0.4s

[internal] load metadata for docker.io/hexpm/elixir:1.12.2-erlang-24.0.3-debian-bullseye-20220801-slim:


Error error building: failed to solve with frontend dockerfile.v0: failed to create LLB definition: docker.io/hexpm/elixir:1.12.2-erlang-24.0.3-debian-bullseye-20220801-slim: not found

Halp?

I’m seeing the exact same error (also trying fly for the first time, attempting to deploy a phoenix app).

EDIT: I was able to solve this issue in my project by replacing the base image in the dockerfile with hexpm/elixir:1.14.0-erlang-25.1-debian-bullseye-20220801-slim

Hi!

Was that after using fly launch to generate the Dockerfile?

I wonder if we need to update that. I’m not a phoenix dev, but it seems like it’s just a base image selection issue (some base images being removed from Docker Hub perhaps!?)

I had the same error, and also resolved it by selecting a different base debian image, but I used a different one than @slondr found success with. I used bullseye-20210902-slim, finding an image in the hexpm list of images that has your exact elixir/erlang combination available seems to be the path forward.

Was that after using fly launch to generate the Dockerfile?

In my case, yes, it was. Seems like the default base image has been removed.

Thanks, all, changing the ARGS of my Dockerfile to:

ARG ELIXIR_VERSION=1.14.0
ARG OTP_VERSION=25.1
ARG DEBIAN_VERSION=bullseye-20220801-slim

worked for me.