My machine is always "Pulling container image"

app: singee-windmill

I try to stop it, but there’s still an error

> fly machines stop 4d89613b696987
Sending kill signal to machine 4d89613b696987...
Error: could not stop machine 4d89613b696987: failed to stop VM 4d89613b696987: aborted: unable to stop machine, current state invalid, replacing

Sounds like a deployment gone wrong.

You might want to keep the machine around in case it helps folks at Fly debug it; but if you don’t want it around for any number of reasons, fly m destroy 4d89613b696987 -f should get rid of it. Exercise caution.

1 Like

It’s not for production, so I don’t mind to keep it. I can keep the machine so that the fly engineer can debug it.

1 Like

Happening here too, repeatedly. Destroyed the problem machine and retried, same result, checked here and found this thread.

This is blocking deploys. I can get around it every few times by destroying the unresponsive machine. Seems intermittent.


Sorry for the inconvenience. What are the failing machine IDs?

Had the same thing while I was trying to bring back my Postgres DB, gave up and destroyed the machines.

I’ve tried

  1. cloning a previous machine
    fly machines clone 7811694b97d528 --region ams -a dert-gg-production-db --attach-volume vol_n0l9vlpoqlg4635d:/data
  2. running a new machine from scratch and attaching the existing volume using
    fly machines run flyio/postgres-flex:15.3 --memory 2048 --vm-cpus 1 --region ams --volume vol_n0l9vlpoqlg4635d:/path -a dert-gg-production-db

Some of the machine IDs that I’ve created & destroyed

  1. 080e652f625048
  2. 784e290f26ee08
  3. 2874536f043398
  4. e82d492f732248
  5. d891d69b60ee78

Also when you “run” a new machine with the Postgres image, the checks are not setup, which would somehow be there if you create a new Postgres app, so I’m not sure whether not having any checks would have any effect on the app.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.