My App Do not Get Updated After Multiple Deployment

I’m trying fly for the first time and my app has refused to update after changes.

May I ask how you update your app?
did you do fly deploy in the directory of your app?
Have you tried restarting it with fly apps restart APPNAME?

I just did. When I ssh into the app the code hasn’t been updated. I have made more than one change. I’m already on version 6 and nothing has been applied.

By the way, I have tried using no-cache and still go the same result–running a old version of the code.

When I ssh into the app the code hasn’t been updated.

That is weird. just delete the app and re launch it using the same fly.toml, shouldn’t take long. Also are you using Dockerfile? if you don’t mind sending it with the names of files in your directory (ls command) so I can take a closer look. Just relaunch it if you prefer not to.

Yes. I am. I just move some things around in my Dockerfile and the code is now updated.

Here is my directory

Well good that It’s fixed. Later when you encounter such problem just build it and run it in your own machine before updating the code on, Have a nice day.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.