Logs not loading, waiting forever

I am trying to check the logs of my app and can’t manage to see them.

$ fly logs -a [app_name]

Waiting for logs...

And it’s waiting forever. Same as if I run flyctl logs in my machine.

Any ideas what could be wrong?

1 Like

Hi @lpares12

Application logs are only kept for 2 days. If your app hasn’t logged anything < 2 days the output will be empty like you are seeing. There are a couple of options for log retention, fly-log-local and fly-log-shipper. Hope that helps.

I have the same problem on my app, it logs regularly as it’s very active but the logs command blocks forever. This has started to happen recently.
I came to the forum to see if it was just me. Apparently not.

This is happening to my app as well.

It has made diagnosing issues impossible.

EDIT: I have tested on Powershell 7 on Windows 10, and on WSL2 Ubuntu.

Same here. Stuck at “Waiting for logs” in the web interface. And not refreshing using the console (fly logs -a ..) where I should see regular /healthcheck test.

Is something wrong currently ?

Same problem here, haven’t been seeing any new logs for the last hour - looks like there’s an outage at least in fra.

I have the feeling since my last deployment something is out of sync O_o

The app[6801xxxx] mentioned in the (last and outdated) logs are not related to the last deployment presented under the log window.

I’m deployed in FRA as well.

Hi all, thanks for the reports. There is indeed something going on with logs and the status page has just been updated. https://status.flyio.net/

(edit: you can follow progress at Fly.io Status - App Logs are Down)

4 Likes

The status page says it has been resolved but I still can’t access the logs.

Thank you

Hi @muddi900, can you provide your app name? Remember, application logs are only kept for 2 days. If your app hasn’t logged anything in 2 days the output will be empty.

I just ran a request to the healthcheck endpoint:


StatusCode        : 200
StatusDescription : OK
Content           : {}

RawContent        : HTTP/1.1 200 OK
                    Server: Fly/5f2bf728
                    Server: (2022-11-11)
                    Date: Fri, 11 Nov 2022 20:59:13 GMT
                    Connection: close
                    Access-Control-Allow-Origin: *
                    Via: 1.1 fly.io
                    fly-request-id: 01GHM7TKKZX3ZKJ3Y1…
Headers           : {[Server, System.String[]], [Date, System.String[]], [Connection, System.String[]],
                    [Access-Control-Allow-Origin, System.String[]]…}
Images            : {}
InputFields       : {}
Links             : {}
RawContentLength  : 3
RelationLink      : {}

The app name is tpw-fam-app. It’s a flask-based API.

Thank you

To add another datapoint - I can see my logs using flyctl, but my online dashboard has just been showing “waiting for logs…” since Thursday

1 Like

Another datapoint:

  • I do not see logs in Sign In · Fly/monitoring for 2/2 apps
  • I do see logs locally, but they are very delayed. I acknowledge logs might not post immediately, but it’s frustrating to not see logs update for hours after the expected log time

Edit: Of course after I send this, I start to see logs in fly.io… first time in weeks!

The same issue persists on the online panel for me as well.

@muddi900 the last log message ( an error message ) from your app appears to be from October. can you try restarting the app?

i think im facing the same issue, no logs, my app is running, but cant get any response or log

I just tried a failed deploy, and the logs still don’t work.

@muddi900 @cmaismais can you both provide the following from your ~/.fly/config.yml? only the following, please DO NOT post private keys :slight_smile:

 peer:
      peerip:
      endpointip: 
      pubkey: 

** where the org matches your app with log issues.

I redeployed the app and it is working again.

1 Like

I still experience this issue.

1 Like