Livebook launch doesn't work properly.

I tried using the Fly launcher to install a Livebook app, the first part worked fine but it installs an older version and informs me I should upgrade it to 0.10. Also within Fly it wants me to upgrade to V2 from Nomad but this fails and locks the app so I cannot even delete it.

I see other issues about this: livebook from launcher

But no replies on how to solve this issue to get the latest version of Fly 0.10 running on V2.


It finally tried to work then failed.

The app is currently locked - this lock expires at 2023-07-15T14:38:43Z
? Remove this lock? Yes
The app's platform version is 'detached'
This means that the app is stuck in a half-migrated state, and wasn't able to
be fully recovered during the migration error rollback process.

Fixing this depends on how far the app got in the migration process.
Please use these tools to troubleshoot and attempt to repair the app.
No legacy Nomad VMs found. Setting platform version to machines/Apps V2.

Just a note that, as of the last hour or so[1], the launcher now launches a Machines app rather than Nomad. That might fix one of your issues.

As per the other, I did wonder about that hard-coded version in the launcher. I’ll see about bumping it, but you may be able to just update the version by saving your app’s config and re-deploying.

  1. I assume so anyway, I just merged the change and assume we deploy regularly from master.

Awesome thanks, I’ll give it a try.

It should be deploying 0.10 automatically now too–looks like my PR got merged while I was out to lunch. Enjoy, please let us know if you have any further issues.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.