Limit instances

I just started using and migrated my Heroku app with you guys,
which is a discord bot, and the problem that I have is that it
automatically created 2 instances, and I’m seeing duplicated
responses, how can I stop this?

I searched but I couldn’t find anything, some people talk about a
configuration of a file, but i don’t see that file, I don’t know where
to look for it because it was migrated from heroku

can you try doing fly autoscale disable and fly scale count 1?

can you please guide how to do that ? i have try but i dont find a way

My project was automatically migrated from heroku , so there is no config file , nothing I can not connect to the app using the terminal

i tried fly autoscale disable --app qa-bot-gh
fly scale count 1 --app qa-bot-gh
but eveything stays here

is like if the deployment hasnt finished but the app is responding

my info says this

I don’t think what you are seeing is unexpected: qa-bot-gh has two VMs running as it is a 2-process Fly app (process1 running in vm1 is named app, process2 running in vm2 is named worker).

You may want to rename the process named app to server or some such (why?).

As to where to find your migrated app’s fly.toml, I am not so sure, but someone else may be able to help you figure out.

Yes I was able to solve it thanks

1 Like