large docker image fails to run

> fly machine run unityci/editor:ubuntu-2020.3.34f1-windows-mono-1
Searching for image 'unityci/editor:ubuntu-2020.3.34f1-windows-mono-1' remotely...
Error You hit a Fly API error with request ID: 01GR4SV9ZE81QF02SGW1B1GWGH-arn

The image size is unfortunately 6.55GB. Is there a limit?

1 Like

There’s just enough space on rootfs to mount a 6.5G image…

Previously, Michael mentioned that 4G images were perfectly fine (but a single layer larger than 2G were not): 2.2 GB docker image is not uploading. - #12 by michael

The largest layer is 6GB, though I have no trouble uploading the image to the fly registry manually. I get the same error using fly machine run after doing so.

Yeah actually running anything over 2gb is not going to work for the most part. You might have a bit of leeway but for now 6gb is definitely too big.

1 Like

I have split the layers in the container so they are no larger than about 800MB but hit the same error, so does this 2GB size restriction apply to the container as a whole?

I think so. I wouldn’t try deploying a 2GB as that would probably encounter quite a few issues.

I’d suggest using a startup script that downloads the data you need on boot.