kombu.exceptions.OperationalError: max daily request limit exceeded. Limit: 10000, Usage: 10000. See https://upstash.com/docs/redis/troubleshooting/max_daily_request_limit for details

i had a problem with my app.
it worked fine until the last week.
my fly logs return suddenly since 6 days the following error:

kombu.exceptions.OperationalError: max daily request limit exceeded. Limit: 10000, Usage: 10000. See ERR max daily request limit exceeded - Upstash Documentation for details

my application ist not connected with the Upstash Redis database, i use the postgresql database.
I don’t know were und how i can resolve this issue

in the upstash Redis section of my dashboard i have the following wanning message on the top of the page:
Experimental We’re getting better at tracking usage! This data is likely incomplete and being actively worked on. We’re doing our best to bring you a great experience, so don’t be alarmed if this keeps changing.

can someone help me please?

Added redis and removed postgres

Hi @Martial!

From the error message, it sounds like your app might still be connecting to Redis, especially with Kombu.

Pricing for Upstash Redis just changed at the beginning of January, and your app is exceeding the number of connections for the free tier, which is why you’re seeing this error.

A few things to check:

  • What does fly redis list give you? That should tell you if any Redis databases exist for your organization.
  • Your Django app might be using Redis for caching, which could cause you to exceed the Upstash free plan limits. Do you happen to have the django-redis package installed? A similar situation recently happened to me with a Rails app when I wanted to remove Redis connections it was making and I neglected to change the cache settings.
  • Does Redis or a package that requires it show up in your application’s requirements.txt?
  • If you’re using Celery, you can check the CELERY_BROKER_URL, which would likely be set as a secret. To view your app’s environment variables, you can run this command: fly ssh console -C "printenv". Or perhaps another setting might reveal where your app is connecting to Redis.
1 Like

Hi @christopher-fly,
effectively i use Celery in my app and my Broker and Worker are all connected to …my_app-redis.upstash.io.
I increased the size of my redis-database an the error message is now dissapear.
Thanks for the support.

1 Like