Issues with Google indexing after deployment: Failed: DNS error: host unknown

Hey, everyone.

I deployed my Rails app to Fly on March 1st.

But I quickly ran into issues when trying to request Google to index my website (via Search Console). I figured this may have been because it was a new deployment so it needed some time.

But 25 days later and I’m still running into the same error each time I request an index:

URL is not available to Google. Failed: DNS error: host unknown

This is strange. I’ve set up my certs just as Fly recommends. I set up the CNAME, A, and AAAA records (with @) that Fly provided with GoDaddy. When I click the check button inside Fly everything is green. I have no issues visiting my domain. And so it appears that I’ve set up everything the right way.

I’m not sure what else I’m supposed to do. For reference this is a Rails app.

It seems I’ve forgot to configure something within Fly? If anyone can point me in the right direction I’d greatly appreciate it.

Strange …

Sounds like it’s only Google(bot?) that is having an issue getting to your site.

When you go into the Google Search Console, is that the error you see when you inspect any URL (e.g from the search box at the top of that site)?

To check your DNS is correct as far as Google sees it, you can use this online tool, replacing “” at the end of this URL with your own domain, naturally:

… and check the A and AAAA are returning as expected. I don’t think you need the A/AAAA and the CNAME record (it’s usually either, not both), so maybe you could remove the CNAME to [name] while at it. Just to see what difference that makes, if any.

Does https://www.<domain> work for you?

The google error suggests it’s a DNS issue, which would most likely mean they’re not getting a good response from Godaddy.

Thanks, Greg.

Dig recognizes the A and AAAA records but not the CNAME records, so I removed it likes you recommended. But I’m still getting the same error in Search Console.

Hey, Kurt.

Yes, all the common variations work for me.

Very strange issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.