High latency using Upstash Redis

Hello! I’m following from this thread Preview: Managed Upstash Redis with read replica support - #5 by thiagosydow

I recently migrated my application from Heroku (Rails app) and everything is working fine, except for Redis. I created an instance using fly redis create and connected to my app. Both are in the same region (dfw). The image below show close to 1 second calls , not only for get/set but also other commands (connect, auth). I switched back the app to use the Heroku Redis instance for the moment until I find a solution for this.

Let me know what extra information would be helpful here.

1 Like

hey @thiagosydow
Which network monitor tool do you see? ( in screenshot )
I would like to reproduce this issue and see what is going on.

Hi @bi1 , the screenshot is from NewRelic, which is what I use for monitoring the app

After some networking sleuthing, we got some more clues internally about the cause of intermittent latency and are looking into it. Thanks for your feedback!

That’s great @jsierles ! Let me know if you find something so I can test it again

Hi @jsierles ! Do you have an update here? I just shutdown my Heroku project since everything is smooth in Fly.io, but when I switched the Redis URL, things got slower. Not as slow as before but still slow.

Since my app small (does not yield much money or anything), feel free to ask or request access to anything that can help (code, config in Fly etc…)

1 Like

The previous issues were fixed, but a new ones have popped up last week. The good news is that the root cause was identified and is being worked on.

Root cause here, I’ve worked on myself and deployed a fix and latencies should look much much better now.

Hi @amos, I just checked and indeed I see the numbers I expected to see. It seems fixed now!

Thank you very much for all the hard work @amos and @jsierles!

1 Like