Getting ENOTFOUND for fly-global-services on new apps

I’ve been using Fly for several months to run stateful UDP services, and it’s worked quite well. Today however, I went to deploy the same (previously working) code in 2 new regions (HKG and OTP) and it seems like fly-global-services cannot be resolved on the new machines. (An additional note, since these are stateful services, I’ve been deploying only 1 machine per app, so each new region = a new Fly app as well)

The previous deployments were Apps V1 and I had tried to move to V2 with these ones, so I thought that might be the issue, but it seems to be a problem on both versions. Both machines had a dedicated IPv4 address allocated. When they try to bind to the address in Node, they both fail with:

Error: getaddrinfo ENOTFOUND fly-global-services
at GetAddrInfoReqWrap.onlookup [as oncomplete] (node:dns:109:26)

This actually ended up being an issue on my end. I have an env var used to pick between IPv4/IPv6 sockets, and it seems that something changed, either in how that got transferred to the Fly machine, or in how it was parsed by my code, but it wasn’t being parsed correctly. So my program was trying to use an IPv6 socket to bind to fly-global-services, which isn’t going to work. Fixing that makes everything work again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.