flyctl postgres actions timing out

Trying to run flyctl postgres db list -a my-postgres-app-name and getting the following error: Error machines could not be retrieved failed to list VMs: Get "http://[...]:4280/v1/apps/my-postgres-app-name/machines": connect tcp [...]:4280: operation timed out. I was getting this on all flyctl postgres actions last night so I’m assuming that’s the case today as well but only tested this one. A friend has tried and it’s working fine for him. That app name is definitely correct and exists and appears to be running correctly if the dashboard is to be believed. Anyone got any ideas?

Hi @csuzw ,

I would suggest you give it a try after some time. Looks like a network issue.

It’s been 3 days. Same error every time I try and I’ve tried at various times on all 3 days. I’m assuming now this is actually a problem with the postgres cluster/machine itself now but the dashboard is still saying it’s healthy and my app can connect to it so I’m unsure.

If I try flyctl info -a my-postgres-app-name it also fails with the same message. If I run the same command for my main app then it’s fine.

There’s nothing unusual about my postgres cluster. It’s just the most basic one I could create using flyctl postgres create and fly postgres attach. My app has been able to connect and read/write to the database.

I really want to like but every time I use it I encounter some issue like this and if I’m doing something wrong then the documentation/error messages are not giving me any clues.

I suggest you try updating your flyctl. Looks like a latest version is available.