Fly proxy: operation timed out

I’m trying to connect to my Postgres database using:

LOG_LEVEL=debug fly proxy 15433:5432 -a vo********-db

Unfortunately I’m unable to connect. I get a timeout:

Proxying local port 15433 to remote [vo********-db.internal]:5432
DEBUG accepted new connection from:
DEBUG failed to connect to target: connect tcp [fdaa:***********:2]:5432: operation timed out

What is strange is that it is working on another database using the exact same steps. Could it be that it is related to this specific database?

I tried again after restarting the instance:

fly machine restart 148e44dc050278

Without success :frowning:


I’ve also been experiencing some issues with a Postgres cluster I created yesterday… and so has another user. Either we’re all configuring it incorrectly or there’s a problem at Fly. Wish someone from their team would take a closer look at this :slightly_smiling_face:

EDIT - Here’s mine, and here’s another. Long story short, it’s working but not all the way. That’s three posts on this topic within twenty four hours :thinking:

1 Like

Still not working today, even in console:

PGPASSWORD=********* psql -h localhost -p 15433 -d vo********* -U vo*********

Hanging for a while, then timed out.

The workaround @mayailurus posted here Trouble Connecting to Postgres Cluster - #4 by mayailurus did work for me.

fly m list -a <db-app-name>  # consult the IP ADDRESS column
fly proxy 5432 fdaa:<hex-digits-from-above>:2

But there is certainly something that need to be fixed to make the fly proxy command work.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.