flyctl deploy quit working with context deadline exceeded

I had no problems running flyctl deploy on a Next.js app in a Github repo until yesterday. Now I get as far as Creating build context done, then I get the following error:

Error failed to fetch an image or build from source: error fetching docker server info: Get "http://[fdaa:0:808f:a7b:2d30:3b9:adf8:2]:2375/v1.41/info": context deadline exceeded

Running fly logs shows a warning - Instance reached connections hard limit of 25.

I researched the problem online to no avail I tried deleting the wireguard and creating a new one. I tried increasing the connection hard limit in fly.toml. I tried adding a region in case the default region (sea) was having issues. Nothing works.

Any help? Thanks!

Hey, that context deadline exceeded is probably a connectivity issue, you should retry it(report back if it doesn’t work). And the log-like about your instance reaching the hard limit is not related, it’s related to how many concurrent connections your instance can handle, and the default that is set in fly.toml happens to be 25(basically scale related). There more details on how to increase that here: App Configuration (fly.toml) · Fly Docs

“…probably a connectivity issue…” When I read that it dawned on me that I started using a VPN since my last deploy, and that maybe that was the problem. I disconnected the VPN, ran flyctl deploy, and everything worked as expected. Thank you!