flyctl can't verify access token

So I was trying to launch an app, and got the following error:

can't build tunnel for personal: Post ""

I ran fly doctor and got a FAILED for Pinging WireGuard gateway.
As suggested I ran:

fly wireguard websockets enable
fly agent restart

Now when I run fly doctor it fails immediately. I get a Testing authentication token... FAILED, even though by now I tried the auth login many times, with it sometimes returning an error and sometimes managing to connect. When it returns an error, it’s the following: Error Post "": dial tcp: lookup on [fe80::dafb:5eff:fefb:aff7%en0]:53: no such host

Even if I manage to login, I think there will still be the wireguard issue

Hi manu, it does look like the ipv6 address being used for dns server is invalid. the extra %en0 at the end of fe80::dafb:5eff:fefb:aff7%en0 makes it an invalid ipv6. Check your system’s dns configuration to see if that needs to be updated.

Hi tvdfly! When I look in my network configs the %en0 isn’t there. I’m not quite sure where this is getting added.

I also get this error when trying to launch:

Failed creating the Postgres cluster my-tarot-api-db: flaps: can't build tunnel for personal: websocket: websocket.Dial wss://scl2