postgres attach ssl / server misbehaving

I’ve been having an issue all day where I haven’t been able to attach a new app to postgres. I kept getting this error: ssh: can't build tunnel for personal: lookup

I’ve since tried a bunch of troubleshooting tips I’ve found on here, like running fly agent restart, fly wireguard websockets enable, fly wireguard reset, etc. When i ran fly doctor i got this response:

Testing authentication token... PASSED
Testing flyctl agent... PASSED
Testing local Docker instance... PASSED
Pinging WireGuard gateway (give us a sec)... FAILED
(Error: ping gateway: pinger: lookup on: server misbehaving)

We can't establish connectivity with WireGuard for your personal organization.

WireGuard runs on 51820/udp, which your local network may block.

If this is the first time you've ever used 'flyctl' on this machine, you
can try running 'flyctl doctor' again.

And am now getting this error on almost all commands that concern wireguard lookup on: server misbehaving

Any thoughts on what could be causing this or how i can remedy it?


I came back to this and ran fly wireguard reset again with no error. After that I went through the postgres attach and all worked as it should. It seems like this may have been some kind of connection error that ended up working itself out.

1 Like