flyctl auth login hangs on WSL2

Hello,
I’m trying to use the cli on WSL2 + win 11 and every time I run flyctl auth login it simply hangs there until I hit ctrl+c, then it shows me the URL but it says that “something went wrong”

I’ve tried using the --verbose param as well but it remains the same.

Running flyctl v0.0.325 linux/amd64 Commit: da2b638 BuildDate: 2022-04-28T04:26:35Z

Can you try with LOG_LEVEL=debug?

oh…now that’s new!
flyctl auth login --verbose LOG_LEVEL=debug
WARN failed querying for new release: Get “https://api.fly.io/app/flyctl_releases/linux/amd64/latest”: dial tcp 96.56.80.1:443: i/o timeout

This looks like a general networking issue connecting to our API. Can you try from another device?

Yes…I’ll try from two other devices

I hit the same issue it looks like fly is trying to launch the browser when I do auth login. If I add -i I get

/home/user/.fly/bin/flyctl auth login -i
? Email: mwoodpatrick@gmail.com
? Password: *************
? One Time Password (if any):

What am I supposed to enter for the one time password

If I just answer the “One Time Password” question with a return it does log me in but does not mention that I’m logged in even if I use --verbose