Problem with login

i cannot login in the terminal

i send the command ‘fly auth login’ and the browser open, i log in, and then, nothing happens, then, in the terminal, i press ctrl+c to end the command, and then it show some log, but aways fail

im using wsl2

also, if someone could help me to create an alias to fly, as fly, that would be awsome too

I’ve found the following to be helpful in WSL2:

sudo ln -s /usr/local/bin/xdg-open /usr/bin/wslview

Doing this will enable flyctl to launch your browser, and when launched this way, fly login should work without any need to copy/paste.

Adding the following to your .bash_aliases file will enable aliases to work:

export FLYCTL_INSTALL="/home/totti/.fly"

This change will take effect the next time you open a WSL terminal window.

the file exists, and the browser is oppening anyways, the problem is that, when i sing in on web site, the terminal dont show any response

it does send a response when i press ctrl+c, to end the execution, the it shows that is trying to log in, and it fails

thanks for the alias thing, worked as a charm

Here’s what I see on WSL2 with Windows 11 and the symbolic link from xdg-open to wslview in place:


just when i tried to record, it works, thanks for the help

i just close the browser after the log in, before stop the command