[fly v0.0.540] fly cli proxy new -a argument

fly v0.0.540 darwin/arm64 Commit: bb3374a7 BuildDate: 2023-04-24T04:38:35Z

I updated to the latest fly cli version today and it borked my local environment. When executing my scripts I get the following message:

Error: the config for your app is missing an app name, add an app_name field to the fly.toml file or specify with the -a flag`

I believe the error message is referring to this line:
fly proxy 6379 my-upstash-instance.upstash.io &

which no longer works. I tried specifying the -a argument, but wasn’t sure what my ‘app name’ is for my upstash. I tried many variations, nothing has worked.

After posting this I felt a divine intervention and figured it out.

On v0.0.540 of the fly cli, here’s how to proxy to Upstash

fly proxy 6379 myupstash.upstash.io -a myapp

Hey @rustygopher, I’m glad you got it working!

I looked into this a bit further, and it appears that you’ve discovered a regression introduced in flyctl v.0.0.507 that affects multiple commands. I just merged a fix. Thanks so much for reporting!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.