Fly Machine - Virtual machine exited abruptly - Following App Guide

Hey friends, been following the user guide (Running user code on Fly Machines · Fly Docs) and can’t quite get it working right.

After deploying a machine I keep getting an error saying ‘Virtual Machine exited abruptly’

I’ve tried deleting all my apps/machines I created the first go around at this and starting over. Same issue. Visiting the URL for this app just hangs indefinitely.

Not quite sure how to troubleshoot this error message. Any help would be greatly appreciated :slight_smile:

Hi @kennethcassel, sorry you’ve had a bad experience following the user guide! We had pushed a fix for this issue a while back but accidentally pushed an image for arm64 instead of amd64. We pushed up the correct image a little bit ago and I was able to deploy a machine successfully.

If you’d still like to try out machines, please feel free to give it another run and let us know how it goes.

1 Like

Thanks for the fast response. Tried it again and now it works!

Also as a side note, I ran into an issue in one of the code snippets on that same page too.

The trailing comma on the line with “network” causes this error {"error":"invalid character '}' looking for beginning of object key string"}

curl -i -X POST \
-H "Authorization: Bearer ${FLY_API_TOKEN}" -H "Content-Type: application/json" \
"http://${FLY_API_HOSTNAME}/v1/apps" \
-d '{
  "app_name": "user-functions",
  "org_slug": "personal",
  "network": "user-functions-network",
}'
2 Likes

Glad things are working now and thanks for the note about the docs, we’ve pushed a fix that should be reflected on the docs site shortly.

2 Likes