SSL Certificate not secure on iOS Safari


I have a deployed a Fly app, with a custom domain, and SSL, and everything works great on desktop in all browsers, and it’s shown as secure with little padlock and everything.

However when I visit my app on iOS Safari the site is shown as insecure.

I assume Fly uses Let’s Encrypt, and found this forum post:

Is it possible is misconfigured in this regard?

We are sending the full chain. I’ve been visiting apps hosted on our platform (such as our own) on my iPhone for years and I’ve never seen that issue. I just visited a site hosted on us for a freshly generated certificate and it appeared to work as expected.

On your iOS device, are you on the same network as your desktop computer? Do you have the same DNS settings? I’m wondering if you’re not hitting the same servers and if this is a DNS propagation issue.

I tried to find your hostnames, but I see you don’t have any apps associated with your user.

1 Like

Thanks for confirming it should work!

I tried visiting my site again on a different network, and now it works :confused:

I’ll try to clear out caches, give propagation a little time, etc., and then see if it occurs again on the other network. Thanks for your response!


1 Like