- first lap around the track

I am new to and I am trying to deploy and test my app and running into multiple issues.

  1. Language: Python

  2. Framework: Flet

  3. Database: SQLite3

  4. Folder Structure, check.

  5. fly.toml file in the same location as the main file, check.

  6. Dockerfile in the same location, check.

  7. requirements.txt file in the same location, check.

When I run the file, everything loads correctly, but when I go to launch the link, it times out or is unreachable.

Now I got a different issue with the following error message:

Error: input:3: createRelease Deploying over the remote builder is not allowed

Can anyone offer any advice on how to fix the files so I can deploy and test my app?


app = "<name>"

kill_signal = "SIGINT"
kill_timeout = 5
processes = []


  allowed_public_ports = []
  auto_rollback = true

  http_checks = []
  internal_port = 8080
  processes = ["app"]
  protocol = "tcp"
  script_checks = []

    hard_limit = 25
    soft_limit = 20
    type = "connections"

    force_https = true
    handlers = ["http"]
    port = 80

    handlers = ["tls", "http"]
    port = 443

    grace_period = "1s"
    interval = "15s"
    restart_limit = 0
    timeout = "2s"


FROM python:3-alpine


COPY requirements.txt ./
RUN pip install --no-cache-dir -r requirements.txt

COPY . .


CMD ["python", "./"]

Hi @PaladinXIV,

If you run fly apps list you should see an app called fly-builder-<something> – that’s your remote builder app. It doesn’t cost you anything; it’s what builds your Docker image when you deploy.

That error message is what you’d get if you pass the name of your builder app to fly deploy, either in your fly.toml file or with the fly deploy command, so that’s the first thing I’d check.



Did you try running fly logs to see if you had any specific error output from the app after running fly launch and/or fly deploy ?

That sort of sounds to me like the app failed to start.

Can you also run fly status and see what it says?

1 Like

I tried your suggestion. Thank you.
I can get it to:

✔ Machine [app] update succeeded

But when I try to go to the URL,:

502 Bad Gateway

So the hunt continues.

Hi, Yes, I have tried looking at the logs. I like it. You get a lot of information from the logs!
The log has identified a couple of issues I addressed, but not I have to figure out a 502 Status Code.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.