fly deploy not working for my Django app

I’m trying to deploy my Django app using the fly deploy command but getting the error:

Error: failed to fetch an image or build from source: error building: failed to solve: rpc error: code = Canceled desc = grpc: the client connection is closing

I tried to follow the solution in this thread, but I can’t find the Windows command to downgrade fly to v0.1.58.

Here is the content of my fly.toml:

app = "damilola"
primary_region = "lhr"
console_command = "/code/ shell"


  release_command = "python migrate"

  PORT = "8000"

  internal_port = 8000
  force_https = true
  auto_stop_machines = true
  auto_start_machines = true
  min_machines_running = 0
  processes = ["app"]

  guest_path = "/code/static"
  url_prefix = "/static/"
1 Like

@damilola could you share which version of the Fly CLI you’re running, and on which version of Windows?

To downgrade, I believe you would have to:

  1. Manually download the installation script at
  2. Run it with something like powershell.exe -file install.ps1 -v v0.1.58. I haven’t tested this at all though so YMMV

Personally managed to get past this step on Windows 8.1 with Fly v0.1.117, but for me it failed at the fly ssh console step.

@thibaudcolas Thank you for the help.
I used the latest version of flyctl, v0.1.119 but got the same error.

Also, I followed your instructions by manually downloading the installation script and then attempting to downgrade to v0.1.58, but Fly downloads the latest version every time I try the command powershell.exe -file install.ps1 -v v0.1.58

For more context, I’m on Windows 10 Pro.

Just wanted to follow up on this to say @damilola managed to make deploy work by downgrading to version v0.1.58. We managed to downgrade by manually editing Fly’s install.ps1 script.

This fixed deploy, unfortunately as reported in the now-unlisted and locked flyctl deploy not working, the CLI keeps on auto-updating so this isn’t really a viable option for more than a one-off.