Fly CLI restart machine with custom signal not working

If I run

fly m restart --select --signal SIGTERM

the signal is ignored and a SIGINT is sent anyways.

We have a kill_timeout in fly.toml of 5 minutes, so to restart an app it takes a long time without the custom signal.

Am I doing something wrong?

I’ve deployed a fix for this bug. Can you try again?

Hey, I’ve updated flyctl and it didn’t work out.

Maybe it’s because I have these settings in my fly.toml?

kill_signal = “SIGINT”
kill_timeout = 300

Are you running the same command, fly m restart --select --signal SIGTERM? What is the output of fly logs when you run that?

This is the exact command I am using:

fly m restart --select --app workers-api-production --signal SIGTERM

This is the only relevant log:

2024-04-26T22:34:31Z app[683d3ddcd3de48] iad [info] INFO Sending signal SIGINT to main child process w/ PID 323

The other ones for the next 5 minutes (because of my kill_timeout setting I think) are just from my app. After 5 minutes the SIGTERM signal is sent, to finally kill the machine.

I think I’ve fixed it for real this time, give it another shot

Hey, now it’s working! Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.