Failed to start remote builder heartbeat: You hit a Fly API error with request ID

I am getting this error today trying to deploy an app. I tried building local but while the app builds, it won’t start on and the cli is complaining about " tls: failed to verify certificate: x509: certificate has expired or is not yet valid: “” certificate is expired"

Seems there are some problems? is reporting all is ok…

Still having this problem after 3 days :frowning:

The server’s certificate is definitely valid:

openssl s_client -connect 2>/dev/null \
| openssl x509 -noout -dates

notBefore=Jun 17 23:37:40 2023 GMT
notAfter=Sep 15 23:37:39 2023 GMT

Please confirm that your machine’s datetime is correct.

  • What CLI command are you running?
  • Are you able to provide a minimal repro of the error?
  • What version of flyctl are you using?
1 Like

Hi, I am simply trying to do a fly deploy but keeps getting a

failed to fetch an image or build from source: error connecting to docker: You hit a Fly API error with request ID

If I build locally fly deploy --local-only, it works.

I am using the latest version of the cli, it’s always kept up to date

Destroying the builder machine fixed it. I did hat too some days ago, without any change, so I have no idea why it worked this time, but it did

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.