failed to launch VM: Not authorized to access this dischargeroottoken

I’ve got Github Actions configured to deploy and that’s currently failing with a dischargeroottoken error. This worked fine until now.

    needs: test
    name: fly-deploy
    runs-on: ubuntu-22.04
      - uses: actions/checkout@v3
      - uses: superfly/flyctl-actions/setup-flyctl@master
      - run: flyctl deploy --remote-only
          FLY_API_TOKEN: ${{ secrets.FLY_API_TOKEN }}

The error.

--> Pushing image done
image size: 546 MB

Watch your app at

Running retrevo release_command: bin/rails fly:release
Error: release command failed - aborting deployment. error running release_command machine: error creating a release_command machine: failed to launch VM: Not authorized to access this dischargeroottoken

Error: Process completed with exit code 1.

Any idea how to fix this? Much appreciated.

Solved by resetting the deploy key.

1 Like

Did you just replace your GH secrets FLY_API_TOKEN? My containers were just moved to the V2 platform today and now it’s no longer working for me, even after getting new tokens using fly tokens create deploy -x 999999h.

I believe it probably has to do with the deploy tokens being issued for each container being marked FlyV1, whereas that’s no longer compatible with my container. How can I get V2 deploy tokens?

Would appreciate any help!

My tokens are also marked FlyV1 but we have moved to Fly V2, so not sure.

It’s understandably a bit confusing, but the FlyV1 does not refer to apps platform version. I believe it’s an identifier for the token schema.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.