"failed to launch VM: EOF" when following the Elixir getting started guide

I wanted to try hosting my apps on fly, but I got this error:

Error: release command failed - aborting deployment. error running release_command machine: error creating a release_command machine: failed to launch VM: EOF

Maybe I’ve done something weird with my app, so I tried to set all up from scratch by following the Getting started guide for Elixir, but I still get the same error.

I have no idea how to debug this or what I’m doing wrong.

  • I’ve tried the “cdg”, “mad” and “arn” regions
  • phx_new is updated: phx_new 1.7.2
  • the “helloelixir-db” app has green checkmarks

What else should I do?

This is an output from rerunning fly deploy:

> fly deploy
==> Verifying app config
Validating /home/tree/code/hello_elixir/fly.toml
Platform: machines
✓ Configuration is valid
--> Verified app config
==> Building image
Remote builder fly-builder-dawn-shape-6188 ready
==> Creating build context
--> Creating build context done
==> Building image with Docker
--> docker host: 20.10.12 linux x86_64
Sending build context to Docker daemon  155.8kB
[+] Building 0.9s (28/28) FINISHED
 => [internal] load remote build context                                                                                                                                                                                                  0.0s
 => copy /context /                                                                                                                                                                                                                       0.1s
 => [internal] load metadata for docker.io/library/debian:bullseye-20230109-slim                                                                                                                                                          0.7s
 => [internal] load metadata for docker.io/hexpm/elixir:1.14.3-erlang-25.2.2-debian-bullseye-20230109-slim                                                                                                                                0.7s
 => [builder  1/17] FROM docker.io/hexpm/elixir:1.14.3-erlang-25.2.2-debian-bullseye-20230109-slim@sha256:f8716e4a7fd1ee7a0da8219e3af7ffba01b3c231855d3008588f908491c0c778                                                                0.0s
 => [stage-1 1/6] FROM docker.io/library/debian:bullseye-20230109-slim@sha256:98d3b4b0cee264301eb1354e0b549323af2d0633e1c43375d0b25c01826b6790                                                                                            0.0s
 => CACHED [stage-1 2/6] RUN apt-get update -y && apt-get install -y libstdc++6 openssl libncurses5 locales   && apt-get clean && rm -f /var/lib/apt/lists/*_*                                                                            0.0s
 => CACHED [stage-1 3/6] RUN sed -i '/en_US.UTF-8/s/^# //g' /etc/locale.gen && locale-gen                                                                                                                                                 0.0s
 => CACHED [stage-1 4/6] WORKDIR /app                                                                                                                                                                                                     0.0s
 => CACHED [stage-1 5/6] RUN chown nobody /app                                                                                                                                                                                            0.0s
 => CACHED [builder  2/17] RUN apt-get update -y && apt-get install -y build-essential git     && apt-get clean && rm -f /var/lib/apt/lists/*_*                                                                                           0.0s
 => CACHED [builder  3/17] WORKDIR /app                                                                                                                                                                                                   0.0s
 => CACHED [builder  4/17] RUN mix local.hex --force &&     mix local.rebar --force                                                                                                                                                       0.0s
 => CACHED [builder  5/17] COPY mix.exs mix.lock ./                                                                                                                                                                                       0.0s
 => CACHED [builder  6/17] RUN mix deps.get --only prod                                                                                                                                                                                   0.0s
 => CACHED [builder  7/17] RUN mkdir config                                                                                                                                                                                               0.0s
 => CACHED [builder  8/17] COPY config/config.exs config/prod.exs config/                                                                                                                                                                 0.0s
 => CACHED [builder  9/17] RUN mix deps.compile                                                                                                                                                                                           0.0s
 => CACHED [builder 10/17] COPY priv priv                                                                                                                                                                                                 0.0s
 => CACHED [builder 11/17] COPY lib lib                                                                                                                                                                                                   0.0s
 => CACHED [builder 12/17] COPY assets assets                                                                                                                                                                                             0.0s
 => CACHED [builder 13/17] RUN mix assets.deploy                                                                                                                                                                                          0.0s
 => CACHED [builder 14/17] RUN mix compile                                                                                                                                                                                                0.0s
 => CACHED [builder 15/17] COPY config/runtime.exs config/                                                                                                                                                                                0.0s
 => CACHED [builder 16/17] COPY rel rel                                                                                                                                                                                                   0.0s
 => CACHED [builder 17/17] RUN mix release                                                                                                                                                                                                0.0s
 => CACHED [stage-1 6/6] COPY --from=builder --chown=nobody:root /app/_build/prod/rel/hello_elixir ./                                                                                                                                     0.0s
 => exporting to image                                                                                                                                                                                                                    0.0s
 => => exporting layers                                                                                                                                                                                                                   0.0s
 => => writing image sha256:439803bde1c457b9998b89027cf7cb7ecf5522ab30ff38d07f6dfee9de823ab3                                                                                                                                              0.0s
 => => naming to registry.fly.io/helloelixir:deployment-01GYYF6JMFY7X9EF1TWFQ7ME7G                                                                                                                                                        0.0s
--> Building image done
==> Pushing image to fly
The push refers to repository [registry.fly.io/helloelixir]
01d4e1b1ab90: Layer already exists
147f8903d6d3: Layer already exists
93d6bcb32f34: Layer already exists
5cb83bdde2bc: Layer already exists
a0c1757e6b79: Layer already exists
67a4178b7d47: Layer already exists
deployment-01GYYF6JMFY7X9EF1TWFQ7ME7G: digest: sha256:1cb0db4afe141d0f0ee5f23e56e9b4a60295463c16148a9cba4c0cb5aa465424 size: 1576
--> Pushing image done
image: registry.fly.io/helloelixir:deployment-01GYYF6JMFY7X9EF1TWFQ7ME7G
image size: 124 MB
Running helloelixir release_command: /app/bin/migrate
Error: release command failed - aborting deployment. error running release_command machine: error creating a release_command machine: failed to launch VM: EOF

iam facing the same issue. i wonder if you found any fix yet??

No, I haven’t made any progress.

I get this now as well (not Elixir). I have not seen it before, it just appeared.

Process groups have changed. This will:
 * create 1 "app" machine

No machines in group app, launching one new machine
Error: error creating a new machine: failed to launch VM: EOF

I tried again just now, and everything started to work. So I assume it was a temporary problem on fly’s end.

Same here!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.