Error: input:3: createAddOn Validation failed: Name has already been taken

Hello,
I’ve created an app, created a sentry extension then destroyed the app and created a new one with the same name. Now I was expecting sentry extension to work with this new app but it doesn’t. As if there was no extension. When I try to create extension with fly ext sentry create I get the error in the title. Apparently the extension is there but not linked to my app. Is there a way to delete an extension or linking existing extension to a new app?

Hey! Thanks for bringing this up. We noticed this oversight internally. Are you more interested in the existing Sentry project to work with the new app, or to get a new Sentry project for the new app?

I hit this issue today as well. I tried clearing out the Sentry project and organization thinking those were the duplicate entities triggering the error, but still seeing it. So now I want to create a new org + project in Sentry for my new Fly app with the same name as the one I destroyed.

I’m running into this same issue now. I don’t particularly care about any of the existing stuff, since I hadn’t used it at all before destroying and recreating my app – I just want the integration to work. :pray:

We’ve deployed a change to fix this issue. Now a new Sentry project will be created with a random suffix added to the associated app name.

@drk I realize this won’t solve your use case, but there are tradeoffs to using random names versus reusing an existing Sentry project. Right now it’s possible to change project names in Sentry, so you could manage the naming yourself in the Sentry UI.

2 Likes

Not sure if I’m using the right terms, but I deleted the project in Sentry, but had my org generated by Fly still around when I initially hit the issue. FWIW I deleted the project and the org later which has like a half-day cool down period before it’s actually deleted. Even after the fact I still can’t create a new Sentry extension for my Fly project that re-used the same name.

I’m assuming I need to/should rename my Fly project which isn’t an issue. Was just trying to squeeze in some side project work this weekend and ran out of debug time.

@jsierles Is this issue fixed now? I’m still experiencing the same error on my end.

@Tarocch1 Can you share the app name?

Please give this a try again. We’ve made a change that allows Sentry projects with the same name on different orgs.

I have the same error on my app